taking on water

Discussion of Blazer's line of Bay boats.

taking on water

Postby Milton » Thu Mar 13, 2008 12:13 pm

I have a 2005 2200 Professional, Yamaha 200 HPDI. Has anyone had any problems with excessive water intake? This occurs when I'm running or stopped and the boat takes in a tremendous amount of water. When I turn on the bilge every 15-20 minutes, it will pump constantly for a couple of minutes each time. I can't figure out where the water is coming in at. I can't leave the boat unattended for an extended period of time.
Any thoughts or suggestions?
2005 2200 Professional, Yamaha 200 HPDI
Milton
 
Posts: 6
Joined: Thu Mar 13, 2008 12:06 pm

Re: taking on water

Postby Butch » Thu Mar 13, 2008 12:44 pm

My boat also takes on water. The bildge pump will turn on approx. every couple hours. I brought it back to the dealer and its better but still takes on slowly. Water also backflows into my rear live well when not in use. I don't remember it doing that before I brought it in for repairs. I like the ride and the overall design though. It keeps me on the water, where I want to be.
Butch
 
Posts: 98
Joined: Sun Dec 16, 2007 2:57 pm
Location: Slidell

Re: taking on water

Postby Milton » Thu Mar 13, 2008 2:24 pm

My rear live well does the same thing. I bought a simple rubber plug. When the well is not in use, I use this plug and it has solved my concerns there.
2005 2200 Professional, Yamaha 200 HPDI
Milton
 
Posts: 6
Joined: Thu Mar 13, 2008 12:06 pm

Re: taking on water

Postby neverenough » Thu Mar 13, 2008 2:51 pm

all the above!!!
i filled mine with water and found the scupper seals on both sides and a live well fitting was leaking. 5200..........
2220 professional 300 hpdi
"Never Enough"
neverenough
 
Posts: 156
Joined: Thu Dec 20, 2007 3:46 pm
Location: belauh, fl

Re: taking on water

Postby BBKing » Thu Mar 13, 2008 3:01 pm

My 2220 Pro did the same thing. After several trips looking and trying to find where it was coming from I found it.
The anchor had punched a hole in the back of the anchor storage. :evil: Water came in the anchor storage and
through the hole causing the bilge to run ALOT! I patched the hole and no more water for me. :lol:
Hope this helps! Good Luck and Great Fishing to all!
2220 Fisherman (Black) w/F200
"Hold'em Hook, Hold'em!"
BBKing
 
Posts: 19
Joined: Tue Mar 11, 2008 10:04 am
Location: Orange Beach, AL


Return to Bay Boats

Who is online

Users browsing this forum: No registered users and 2 guests

cron